PDA

View Full Version : 1994 70HP Evinrude



Ferdi
05-23-2006, 06:28 PM
Help!!! Don't have any spark at any cylinder, can you help me out on here? Would really appreciate it. Fred aka Ferdi

Barnacle Bill
05-23-2006, 06:46 PM
Have you checked your kill switch?

FisherMike
05-23-2006, 06:50 PM
The first thing that comes to mind would be the kill switch.
You would be amazed how many times people forget about that.

Go to this site and ask your question though.
http://www.themarinedoctor.com/cgi-bin/YaBB.pl

This guy is great.
You can also do a search on the site and perhaps find an answer.

Ferdi
05-23-2006, 08:05 PM
Yep, I did check the kill switch but will get the thing home tomorrow and put a test on it again. Thanks IBNFSHN AND to FISHERMIKE the site is awesome. Looked thru 46 pages on Johnson and Evinrude. I'll get use out of that site for sure. Appreciate the help. Fred

NIMROD
05-23-2006, 08:19 PM
Yep, I did check the kill switch but will get the thing home tomorrow and put a test on it again. Thanks IBNFSHN AND to FISHERMIKE the site is awesome. Looked thru 46 pages on Johnson and Evinrude. I'll get use out of that site for sure. Appreciate the help. Fred
If not the kill switch , could be power pack ?:confused:

labill
05-23-2006, 09:15 PM
Ferdi..... I had the same prob on my Mariner. I bought a manual from www.iboats.com and using the manual I found out the stator had gone defective and it took out the powerpack and two coils. Had to replace the stator, power pack and replaced all 4 coils. She's humming along now after 2 years.

eddiebhome
05-23-2006, 09:53 PM
Happened to me a couple of weeks ago. I've got a 2005 40hp Merc. Found a fuse block under the cowling and, yep, sure enough, one of those puppies was blown. Luckly I had an extra of the same kind (but wrong amperage) in the truck that worked. Since then I've bought a set to keep in the boat.

Good luck.