SLABSAUCE Crappie Attractant |
Thanks Thanks:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Only to me!

  1. #1
    Join Date
    Aug 2011
    Location
    nc
    Posts
    1,320
    Post Thanks / Like

    Default Only to me!

    Well I posted that my trolling motor was dead and it might be the control board. It wasn’t. Took it to a minn Kota service center and they said I had a dead battery. I told them that they were showing full charge. Come to find out one battery had reversed charge. Nobody can tell me why. Took it back to interstate and they said they had only seen it a couple of times. They said it had to go completely dead and then you hook it up backwards. Only problem with that is batteries are only about 4 months old. Been hooked up in boat with on board charger since new. Just like the 5 year old batteries were. Been working great for months and I always plug in charger when I get home. They are at a lost as am I. The guy said he had been there for years and only seen this a couple of times. Of course it had to be me. Lol. Good news is I don’t have to wait 3 months to use my trolling motor. Bad news is that since it wasn’t the trolling motor and covered under warranty, I had to pay the $116 for them to tell me my battery wasn’t working right. This would happen only to me.
    Likes Clod, BigDawgg LIKED above post

  2. #2
    Join Date
    Feb 2005
    Location
    currituck NC
    Posts
    2,116
    Post Thanks / Like

    Default

    Only things like that happen to me. Glad it worked out for you.

    Sent from my SM-G965U using Tapatalk
    dave
    in currituck

  3. #3
    Join Date
    Mar 2008
    Location
    Newport, SC
    Posts
    5,571
    Post Thanks / Like

    Default

    I agree! If it's going to happen it happens to me too! Glad you aren't motor less!

  4. #4
    Join Date
    Aug 2011
    Location
    nc
    Posts
    1,320
    Post Thanks / Like

    Default

    Yep. worth the $116 to have it back.
    Likes BigDawgg LIKED above post

  5. #5
    Join Date
    Mar 2010
    Location
    OK
    Posts
    23,812
    Post Thanks / Like

    Default

    Quote Originally Posted by cwright View Post
    Yep. worth the $116 to have it back.
    X2! Now go get some fish, and post us a pic.


    Sent from my iPhone using Crappie.com Fishing mobile app
    Proud Member of Team Geezer!

  6. #6
    Join Date
    Aug 2011
    Location
    nc
    Posts
    1,320
    Post Thanks / Like

    Default

    Gona try this morning. Debating between Tillery and the Rock. Let y’all know.
    Likes BigDawgg LIKED above post

  7. #7
    Join Date
    Jan 2011
    Location
    Nawth Carolina
    Posts
    458
    Post Thanks / Like

    Default

    Your battery = #WalkAway

  8. #8
    Join Date
    Apr 2015
    Location
    Illinois
    Posts
    370
    Post Thanks / Like

    Default

    4 month old battery and you had to buy a new one????? Think I would be changing brands if they wouldn't warranty it

  9. #9
    Join Date
    Oct 2019
    Location
    Cameron N.C.
    Posts
    724
    Post Thanks / Like

    Default

    We were having issues with interstate at the boat shop, so we changed to AC Delco $128. 1 yr. warr.
    We had to warranty 1 last yr. None so far this yr.

  10. #10
    Join Date
    Aug 2011
    Location
    nc
    Posts
    1,320
    Post Thanks / Like

    Default

    I have always used interstate, but bought two one was bad from the get go and now 4 months later this issue. I may have to change as well.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP