HaHa HaHa:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 50 HP Evinrude Older 70s Model

  1. #1
    Join Date
    Feb 2011
    Location
    Georgia
    Posts
    60
    Post Thanks / Like

    Default 50 HP Evinrude Older 70s Model


    Need help getting motor to run properly. I'm not a outboard mechanic but work on most things. Motor will run and idle just fine until you place the cover on it. I took the vent cover off it did have a couple dirt dobber nest that I removed, made no difference. I even removed the foam insulation from the under side, no difference. You place the cover after a few seconds on it starts to idle rough and gets worst until it shuts off. I can remove the cover it never happens. I can remove the cover before it shuts off and it straightens up. I set the idle per the manual (750 RPMs in reverse). I even went higher to approx 900-950 and it still does it. Any help would be appreciated.

  2. #2
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    696
    Post Thanks / Like

    Default

    Make sure the vent which is where the rear hand hold is on the cover is open. That's how air gets to the carb

  3. #3
    Join Date
    Feb 2011
    Location
    Georgia
    Posts
    60
    Post Thanks / Like

    Default

    Quote Originally Posted by MDCrappie View Post
    Make sure the vent which is where the rear hand hold is on the cover is open. That's how air gets to the carb
    Thanks, MDCrappie, that's where I found the two dirt dobber nest. I cleaned them out no help. Never seen anything like this. Been having idle issues with this thing for a few years. I could get it to idle but it was much higher than it should be. Purchased a RPM gauge turned it down to manufacturers' setting. It shifts much smoother, like it should but will not idle with cover in place. Runs high speed just fine. Thanks Again Ray

  4. #4
    Barnacle Bill's Avatar
    Barnacle Bill is offline Super Mod and 2014 Crappie.com Man of the Year * Crappie.com Supporter
    Join Date
    Apr 2004
    Location
    Chesapeake, Va
    Posts
    20,502
    Post Thanks / Like

    Default

    Check for an exhaust leak under the cowling.
    Fair Winds and Following Seas

    Bill H. PTC USN Ret
    Chesapeake, Va


  5. #5
    Join Date
    Feb 2011
    Location
    Georgia
    Posts
    60
    Post Thanks / Like

    Default

    Sir, The do have a small leak or I believe I do. I have a small plume of smoke that comes from around the left side. Never would have guessed that would cause a problem. How painful is the repair? Appreciate the help, Ray

  6. #6
    Join Date
    Feb 2011
    Location
    Georgia
    Posts
    60
    Post Thanks / Like

    Default

    Quote Originally Posted by Arayt View Post
    Sir, The do have a small leak or I believe I do. I have a small plume of smoke that comes from around the left side. Never would have guessed that would cause a problem. How painful is the repair? Appreciate the help, Ray
    Sir, I meant to say I do have a small leak vs The do have. Sorry I could not edit post.
    Ray

  7. #7
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    696
    Post Thanks / Like

    Default

    The exhaust should go out the bottom of the block. You'd have to pull the power head and there should be a gasket between the head and the exhaust housing. Hopefully it's he gasket and not the housing.

  8. #8
    Join Date
    Jul 2017
    Location
    MO
    Posts
    984
    Post Thanks / Like

    Default

    Yes, powerhead gasket is likely blown. Not a bad job, just time consuming.

  9. #9
    Join Date
    Feb 2011
    Location
    Georgia
    Posts
    60
    Post Thanks / Like

    Default

    Thanks for the info. I found a drawing that shows 2 gaskets top and bottom of the power head adapter, I assume its recommended to change both? Is there anything else you recommend changing while I have it apart? The motor I've owned for many years, the water pump I'm sure is ok.
    Thanks Ray

  10. #10
    Join Date
    Feb 2011
    Location
    Georgia
    Posts
    60
    Post Thanks / Like

    Default

    Any recommendations on where to buy OMC parts?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP