SLABSAUCE Crappie Attractant |
Thanks Thanks:  0
Results 1 to 5 of 5

Thread: Water Pump Replace

  1. #1
    Join Date
    Nov 2015
    Location
    Louisiana
    Posts
    89
    Post Thanks / Like

    Default Water Pump Replace

    2014 Yamaha 115...Haven't been out with boat in a while so i run it with the muffs on periodically. Last time I ran it, it started and had water coming out the pee hole in little squirts (not a steady stream), but after a couple minutes, the water stopped coming out. I let it run for about 5 more minutes and still no water. Never did this before, but i got a water pump kit and pulled the lower end off and replaced the water pump.

    Not really that difficult a job but being first time I did this it took me a little longer than if I were to do it again.

    When I put muffs on after putting in new water pump, it splits out a steady stream of water. I assume this means I put everything back where it belonged and that I am good to go....gonna take down to river and run it just to make sure...

    Total cost was $43 for replacement kit and about 2 hours off and on labor...Saved me a few bucks and was a good new experience.
    Likes kycreek, "G" LIKED above post

  2. #2
    Join Date
    Mar 2011
    Location
    Wisconsin
    Posts
    451
    Post Thanks / Like

    Default

    Cheap insurance to save a motor as some will say had the motor 10 years and never replaced the water pump WWWEEEeellll. Some just like living on the edge I am not one of those every two years I replace mine.
    Likes "G" LIKED above post

  3. #3
    papasage's Avatar
    papasage is offline Crappie.com 2011 Man of the Year & Moderator GA * Crappie.com Supporter
    Join Date
    Apr 2004
    Location
    Fitzgerald Ga. 31750
    Posts
    6,051
    Post Thanks / Like

    Default

    some times a bug will clog the pee hole . run a wire up it and see what it does.
    retired and now i will always fish

  4. #4
    Join Date
    Feb 2020
    Location
    Hibbing
    Posts
    16
    Post Thanks / Like

    Default

    My Yamaha F25 motor has hose coupling for flushing the cooling system . Sounds like you solved your problem with a new pump but it might be a good idea to flush it once in while.
    Retired member : E Z turn elbow co.

  5. #5
    Join Date
    Nov 2015
    Location
    Louisiana
    Posts
    89
    Post Thanks / Like

    Default

    I flush the motor for at least 20 minutes after every use...Using muffs

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP