SLABSAUCE Crappie Attractant |
Likes Likes:  0
Thanks Thanks:  0
Results 1 to 5 of 5

Thread: Promariner ProSport 20 Plus question

  1. #1
    Join Date
    Aug 2017
    Location
    NE AL
    Posts
    3,401
    Post Thanks / Like

    Default Promariner ProSport 20 Plus question

    This past winter I bought a used 3 bank charger from the personal classifieds on this website to put in the boat that I have been refurbishing. I installed the batteries in the boat yesterday and tried to hook up the charger. When I plugged up the charger the blue power light is flashing slowly. That's the only light that comes on. I tested the leads with my volt meter and 2 of the 3 leads are fluctuating from 14-14.8 volts and the 3rd lead is rapidly fluctuating from 10.5-14.5 volts. None of the 3 leads are really settling in on any one particular voltage and the 3rd is all over the board.

    So is this normal, or did I buy a pig in a poke?

  2. #2
    Join Date
    Mar 2016
    Location
    Alabama
    Posts
    1,205
    Post Thanks / Like

    Default

    Make sure it is set for the right kind of battery you have.

  3. #3
    Join Date
    Aug 2017
    Location
    NE AL
    Posts
    3,401
    Post Thanks / Like

    Default

    It doesn't have any settings on it.

    I called ProMariner this morning. Their tech service said the unit was bad.

  4. #4
    Join Date
    Feb 2008
    Location
    Clarksville, IN
    Posts
    5,831
    Post Thanks / Like

    Default

    Ouch

    Sent from my Z983 using Crappie.com Fishing mobile app




  5. #5
    Join Date
    Dec 2009
    Location
    illinois
    Posts
    9,952
    Post Thanks / Like

    Default

    There is a setting for kind of battery. You turn it with a screwdriver.



    MEMBER CRAPPIE MAFIA

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP