SLABSAUCE Crappie Attractant |
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Humminbird’s latest Updates with new basemaps.

  1. #11
    Join Date
    May 2010
    Location
    Southern Indiana
    Posts
    4,876
    Post Thanks / Like

    Default

    I haven’t had any issues with m 9 G2N MSI using after updating. Did you default before and after you did the update? Just a thought.

    PROUD MEMBER OF TEAM GEEZER
    authorized by: Billbob and "G"

  2. #12
    Join Date
    Mar 2020
    Location
    Missouri
    Posts
    150
    Post Thanks / Like

    Default

    Yes I did. I'm going to remove all my waypoints on the units and see if that helps. I have loaded thousands of them from the Missouri Department of Conservation, so I wonder if it's not crashing because it's just too full.

    I'm going to do everything I can to figure this out, since it sounds like I'm on my own until Humminbird releases another update.

  3. #13
    Join Date
    May 2010
    Location
    Southern Indiana
    Posts
    4,876
    Post Thanks / Like

    Default

    I think there might be a update coming because my new G4N 12 MDI has software version 2.300 loaded in it.

    PROUD MEMBER OF TEAM GEEZER
    authorized by: Billbob and "G"

  4. #14
    Join Date
    May 2010
    Location
    Southern Indiana
    Posts
    4,876
    Post Thanks / Like

    Default

    You might want to wander over to the Humminbird forum on bbc forum and ask any questions you have. They have a lot of issues like yours brought up with questions asked.

    PROUD MEMBER OF TEAM GEEZER
    authorized by: Billbob and "G"

  5. #15
    Join Date
    May 2010
    Location
    Southern Indiana
    Posts
    4,876
    Post Thanks / Like

    Default

    Quote Originally Posted by cevans;[URL="tel:4101252"
    4101252[/URL]]I think there might be a update coming because my new G4N 12 MDI has software version 2.300 loaded in it.
    Big mistake in software version...the new G4N 12:is loaded from the factory with version 3.00 not 2.300. My mistake.

    PROUD MEMBER OF TEAM GEEZER
    authorized by: Billbob and "G"

  6. #16
    Join Date
    Aug 2016
    Location
    Blood River, KY Lake
    Posts
    434
    Post Thanks / Like

    Default

    Quote Originally Posted by rnvinc View Post
    Verify the update is for your specific unit model ...

    The unit will not recognize an update bin file for any other unit model ...
    ——-

    Also ... some update downloads are downloading as a zip folder (not sure about yours) ... if that’s the case the zip folder must be extracted and put on the SD Card ...

    Rickie
    Interesting development. I bought a Helix 10 G3N Mega Chirp DI unit. That's what I ordered, that's what I paid for.

    The update for this model is not recognized when I put the SD card in and fire it up.

    Soooooo, Just out of curiosity, I downloaded the update for the Helix 10 G3N Mega Chirp SI unit, it worked and updated perfectly.

    I also updated the basemap per Humminbirds recommendation..

    All that being said. PRIOR to installing the update, The DI images disappeared this afternoon. The 2D imaging works fine. I think I got a mixed up product from Humminbird. I has non functioning SI views. I think the transducer may not match the unit. Anyway, something's wrong. The DI images never have been right. submerged trees look like fuzzy dog turds. Fisk look like fuzzy balls. My helix 8 G3N Mega SI unit at the console has sharp images of the same objects.

    Probably gonna ship this custom unit back to Humminbird while it's still under warranty.
    2017 Ranger RT188C Shadow Grass Camo
    Mercury 115 Pro XS
    Crappie Novice
    Thanks GrumpyLoomis thanked you for this post

  7. #17
    Join Date
    Aug 2016
    Location
    Blood River, KY Lake
    Posts
    434
    Post Thanks / Like

    Default

    Quote Originally Posted by Northforker View Post
    Interesting development. I bought a Helix 10 G3N Mega Chirp DI unit. That's what I ordered, that's what I paid for.

    The update for this model is not recognized when I put the SD card in and fire it up.

    Soooooo, Just out of curiosity, I downloaded the update for the Helix 10 G3N Mega Chirp SI unit, it worked and updated perfectly.

    I also updated the basemap per Humminbirds recommendation..

    All that being said. PRIOR to installing the update, The DI images disappeared this afternoon. The 2D imaging works fine. I think I got a mixed up product from Humminbird. I has non functioning SI views. I think the transducer may not match the unit. Anyway, something's wrong. The DI images never have been right. submerged trees look like fuzzy dog turds. Fisk look like fuzzy balls. My helix 8 G3N Mega SI unit at the console has sharp images of the same objects.

    Probably gonna ship this custom unit back to Humminbird while it's still under warranty.
    Spent 15 minutes on the phone with Humminbird customer support today. My serial number says my unit is a Helix 10 Mega Chirp DI gps G3N. My system status upon boot up says my unit is a Helix 10 Mega Chirp SI+ gps G3N. Humminbird says the system status trumps the tag on the back of the unit. They are sending me a XTM 9 HW MSI T transducer to see if that fixes the unit. fingers crossed.
    2017 Ranger RT188C Shadow Grass Camo
    Mercury 115 Pro XS
    Crappie Novice
    Likes Redge LIKED above post
    Thanks GrumpyLoomis thanked you for this post

  8. #18
    Join Date
    Mar 2020
    Location
    Missouri
    Posts
    150
    Post Thanks / Like

    Default

    I had several emails back and forth with Humminbird and figured out only one of my units was the issue. It supposedly had one or more corrupt waypoints saved on it. If I tried to click on waypoints, routes, and tracks tab, it would beep and turn off. It would also do this if I tried to zoom in while in chart view. It was doing this on both units when I had them linked, but only the one unit did it while they were not linked.

    They explained how to format the Nav Directory to fix the issue. In doing so, I lost all of the waypoints on the unit, but I had most of mine backed up on SD cards, so it wasn't an issue.

    As irritated as I was from this happening, I realize it was not the update that caused the problem, and they were extremely helpful in helping me resolve it. I am looking forward to getting back out on the water with my G2N units that have provided me several years of enjoyment.

    Somewhat related: I picked up a 3rd Helix for my boat today at MidwayUSA. I bought a G4N Helix 10 Mega DI+ for the bow. I'll keep my 2x G2N 10 Mega SI units at the console, sell my original 360 and extra Mega SI transducer, switch to Mega 360 on the front, and be able to add Mega Live when they are available.

  9. #19
    Join Date
    Aug 2016
    Location
    Blood River, KY Lake
    Posts
    434
    Post Thanks / Like

    Default

    Quote Originally Posted by Northforker View Post
    Spent 15 minutes on the phone with Humminbird customer support today. My serial number says my unit is a Helix 10 Mega Chirp DI gps G3N. My system status upon boot up says my unit is a Helix 10 Mega Chirp SI+ gps G3N. Humminbird says the system status trumps the tag on the back of the unit. They are sending me a XTM 9 HW MSI T transducer to see if that fixes the unit. fingers crossed.
    UPDATE: Installed the SI Transducer on the "DI" control head. Amazingly everything works, including SI. I guess the moral of the story is, maybe the update doesn't work in your unit because your unit has been mislabeled of has an identity crisis! LOL!
    2017 Ranger RT188C Shadow Grass Camo
    Mercury 115 Pro XS
    Crappie Novice

  10. #20
    Join Date
    Sep 2008
    Location
    West Ky
    Posts
    12,244
    Post Thanks / Like

    Default

    Quote Originally Posted by Northforker View Post
    UPDATE: Installed the SI Transducer on the "DI" control head. Amazingly everything works, including SI. I guess the moral of the story is, maybe the update doesn't work in your unit because your unit has been mislabeled of has an identity crisis! LOL!
    Interesting report ... I’ll have to say it’s the 1st of its kind I’ve ever heard of in the forums of a unit being mislabeled ...

    Rickie
    www.podunkideas.com <--Click here
    -----------------
    www.crappie-gills-n-more.com
    www.cornfieldcrappiegear.com
    ------------------------>> Pro Staff Sonar Advisor

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP