SLABSAUCE Crappie Attractant |
Thanks Thanks:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Humminbird Helix 2GN Right Side Imaging Dark Screen

  1. #1
    Join Date
    Mar 2007
    Location
    Pine Mountain, Ga
    Posts
    223
    Post Thanks / Like

    Default Humminbird Helix 2GN Right Side Imaging Dark Screen

    My 10Ē Helix recently has been a dark screen on the right side. Iíve checked and reset the Transducer Angle and inspected for cracks with none visible. Iíve checked connection pins to make sure there wasnít one broken. The left side is still operational.
    Iíve yet to reset the head unit to default and was curious if I need to save my waypoints prior to resetting.
    Just looking for suggestions before I order a new transducer. Thanks for any help offered and tight lines to all.

    Krappie Krane
    Amateur Thump Thump Chaser

  2. #2
    Join Date
    Aug 2011
    Location
    IL
    Posts
    1,319
    Post Thanks / Like

    Default

    You won't loose your waypoints when resetting defaults .... but it is always a good idea to have them backed up ... stuff happens.

    Do you have another unit you can use for troubleshooting .... need to determine if the transducer or the head unit is the problem. Maybe you could test your unit on someone else's boat or the other way around.
    _______________________________________
    Looking for the one that makes it all worthwhile.
    Likes KrappieKrane LIKED above post

  3. #3
    Join Date
    Mar 2007
    Location
    Pine Mountain, Ga
    Posts
    223
    Post Thanks / Like

    Default

    Bob,
    I wish I had that option. My front graph is a Gen 1 and different transducer. All my friends have Gen 3 units. My two units are linked so they share waypoints so I should be good there.
    Just seeing if anyone else has had this issue with the grn 2 and what might resolve it.
    Iíve never done a software update since the unit worked so well. Didnít want to chance a mess up with the update. Guess my hands are kinda tied right now and I may have to do it.
    Thanks for the reply.

  4. #4
    Join Date
    Aug 2011
    Location
    IL
    Posts
    1,319
    Post Thanks / Like

    Default

    A software update will not resolve this problem. I wouldn't do an update til you resolve it. Just one more thing to complicate the issue.

    Most likely is a transducer going bad .... but could be the head unit ... you already checked connections the best you can. You could probably connect your unit to a G3 setup, but there may be some precautions to take. Maybe Rickie will check in and advise you about that.

    Maybe someone else with a G2 unit will see this thread.
    _______________________________________
    Looking for the one that makes it all worthwhile.

  5. #5
    Join Date
    Mar 2007
    Location
    Pine Mountain, Ga
    Posts
    223
    Post Thanks / Like

    Default

    I appreciate the input Bob. I’ve been withholding the slush fund to purchase another unit to add to the console and now may be the time to get off the pot. At least I can still fish with a new one while the old one is possibly getting repaired at Humminbird.
    I did find a transducer locally that I’m gonna try first and see if it resolves the issue.
    And I’m not far from West Point lake and I may see if someone would let me hook up the unit to their transducer while on the water.
    Likes BobB LIKED above post

  6. #6
    Join Date
    Sep 2008
    Location
    West Ky
    Posts
    11,878
    Post Thanks / Like

    Default

    Bob gives good advice ...

    Also definitely try Restore Defaults 1st ... that resolves a lot of issues ...

    What is the G2N unit please ..:??

    Rickie
    www.podunkideas.com <--Click here
    -----------------
    www.crappie-gills-n-more.com
    www.cornfieldcrappiegear.com
    ------------------------>> Pro Staff Sonar Advisor

  7. #7
    Join Date
    Sep 2008
    Location
    West Ky
    Posts
    11,878
    Post Thanks / Like

    Default

    BTW ... your update ideology is sound ...

    One might not need updating unless a certain update fixes a certain gremlin -or unless the update adds a feature that the user wants ...

    Rickie
    www.podunkideas.com <--Click here
    -----------------
    www.crappie-gills-n-more.com
    www.cornfieldcrappiegear.com
    ------------------------>> Pro Staff Sonar Advisor
    Likes KrappieKrane LIKED above post

  8. #8
    Join Date
    Jan 2019
    Location
    Saluda, SC
    Posts
    36
    Post Thanks / Like

    Default

    Dumb question.... Is your outboard in the way? My uncle has to trim his motor up some so he can see off the left side of his boat. Luckily my motor is on a jack plate so it is clear of the sonar beam.

    Sent from my SM-G955U using Crappie.com Fishing mobile app




  9. #9
    Join Date
    Mar 2007
    Location
    Pine Mountain, Ga
    Posts
    223
    Post Thanks / Like

    Default

    The G2N is the second generation of Helix models that can be networked

  10. #10
    Join Date
    Mar 2007
    Location
    Pine Mountain, Ga
    Posts
    223
    Post Thanks / Like

    Default

    I do have to trim the outboard up to allow clearance for the left side of SI. The right side just started messing up two weekends ago and I’ve done all the simple checks to make sure it’s not it’s all connected and plugged in. I wish I had a pic to add to the post.
    The image isn’t completed blacked out. It’s shows a few feet of coverage but then goes dark.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP