SLABSAUCE Crappie Attractant |
Thanks Thanks:  0
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Humminbird Helix 2GN Right Side Imaging Dark Screen

  1. #11
    Join Date
    Sep 2008
    Location
    West Ky
    Posts
    11,884
    Post Thanks / Like

    Default

    Did you try the Restore Defaults yet?

    Rickie
    www.podunkideas.com <--Click here
    -----------------
    www.crappie-gills-n-more.com
    www.cornfieldcrappiegear.com
    ------------------------>> Pro Staff Sonar Advisor

  2. #12
    Join Date
    Mar 2007
    Location
    Pine Mountain, Ga
    Posts
    223
    Post Thanks / Like

    Default

    Rnvinc, I did not get a chance to play with my unit but I did find out that my unit is still under warranty until December. I’ll post any update from resetting to default. Thanks for checking on this ole guy.

  3. #13
    Join Date
    Jan 2019
    Location
    Las Cruces NM
    Posts
    77
    Post Thanks / Like

    Default

    My unit quit showing the temperature. Called Humminbird and while still under warranty, they sent me a transducer. Call them. They will help.
    It wasn't a transducer problem. Sent the unit back and with repairs and turn around I only lost 5 days without a unit.
    Likes KrappieKrane LIKED above post

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP