SLABSAUCE Fish Attractant |
Likes Likes:  0
Thanks Thanks:  0
Results 1 to 2 of 2

Thread: Hummingbird helix 7 di g2?

  1. #1
    Join Date
    Apr 2018
    Location
    Kentucky
    Posts
    546
    Post Thanks / Like

    Default Hummingbird helix 7 di g2?

    My unit is a couple years old and has always worked perfectly, here lately it has been acting silly. First of all the screen clutters up and the bottom line will move up to the top of the screen, I will be in 20 fow and it will all of a sudden GO crazy and show 300 fow or something wild, I also can no longer identify structure because of the fuzzy screen, any suggestions? I havnt changed anything in my boat as to add interference, I might add I run the 2d sonar through my Terrova but I moved the unit to my factory transducer on the back of the boat with same results. Please help if possible, thanks and God Bless

    Sent from my VS988 using Crappie.com Fishing mobile app




  2. #2
    Join Date
    Feb 2005
    Location
    currituck NC
    Posts
    1,889
    Post Thanks / Like

    Default

    I would try to do a factory reset, if that doesn't work, try replacing the software. Make sure you follow the instructions to the letter. I was having trouble with my 899 and there was a post on the Same concern on the HB side imaging. He had corrupt software as I. Might be worth looking into.



    Sent from my SM-G965U using Tapatalk
    dave
    in currituck

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

BACK TO TOP