PDA

View Full Version : My G3 HELP



wvcrappie
04-18-2008, 01:29 PM
Well finally got the boat together and hit a local lake this morning. I couldn't get the little 3.3 Merc to start. Then I noticed some gas flowing out the bottom of the carb. Then I noticed there was a unhooked wire (black) coming from the kill switch, should this be attached (ground)? Now this is a second hand motor I picked up and I've never started it before. So I'm lost not knowing much about it. I think maybe a float is stuck in the carb? Well anyways I managed two nice sandwich slabs. Here's some pics.
http://i10.photobucket.com/albums/a101/Flydabber/CrappieBoat001.jpg
http://i10.photobucket.com/albums/a101/Flydabber/CrappieBoat002.jpg
http://i10.photobucket.com/albums/a101/Flydabber/CrappieBoat003.jpg


wvcrappie

fishmannyj
04-18-2008, 04:53 PM
Nice crappie rig there. Man WV looks great this time of year!

NoMinners
04-19-2008, 05:46 PM
Your float is sunk or you may have dirt under the needle in the seat. Check float for fuel inside. The black wire is hard too say, it depends where it goes. Check spark with a NEW plug with wire off, then ground it and see if you still have spark. You can also do a continuity check on the Kill switch. Nice fish.

wvcrappie
04-20-2008, 08:47 PM
Well we're pretty sure it's the carb loading to much fuel. We opened up the carb and I don't think there was a needle valve.:confused: Ordered a carb rebuild kit so I guess we'll see. It's getting fire out the plug so I don't know what else it could be?




wvcrappie