PDA

View Full Version : ? For the Millennium



wendell c
03-11-2019, 07:09 PM
Hey guy !Just got 4 of the R100s and they are stought ,
but do you ride to lake with them installed or no ?

tlefire
03-11-2019, 08:14 PM
Yessir and never had a problem. 2 up front and 2 in the rear. Just make sure there all tight.

"G"
03-11-2019, 08:26 PM
I never take mine off....ride the high way with them too

jp2
03-11-2019, 08:30 PM
I don't, take mine off. They are a little top heavy and don't think all the shaking and bouncing could be good on mounts.

Cray
03-11-2019, 10:16 PM
I have had one come loose bouncing down the hwy. make sure the base bolts are tight and the one that holds the T bar in place. Have heard others complain about the T bar bolt. I think mine is caused by where I have it mounted that allows it to shake back and forth. Just try it and stop and check every once in awhile. You will figure out pretty quick if it works for you or not. I don’t find it a major inconvenience to just unscrew two bolts and lay in floor.

dwightparks
03-12-2019, 10:14 AM
What Cray said. Not worth loosing going down road.

silverside
03-12-2019, 11:11 AM
Mine have to be unbolted so I don't worry about it.

Sent from my SM-G960U using Crappie.com Fishing mobile app (http://r.tapatalk.com/byo?rid=87936)

wendell c
03-12-2019, 01:20 PM
Thanks everyone ! Yea just 2 bolts not worth it thanks again !

CrappiePappy
03-12-2019, 03:19 PM
If you're worried it might pop out ... why not use a bungie cord & strap it down to the front cleats ??

deltarat
03-12-2019, 08:57 PM
I have 4 and they ride 60 mile to the lake and back and never had any trouble. Just check them before you leave and before you leave the lake.