PDA

View Full Version : What depth finder would you choose



sliles
06-23-2011, 10:24 PM
Lowerance HD 10 with side scan
Hummingbird 1198 side scan

cschottfish
06-24-2011, 11:27 AM
Love my 898, I would stay with the hummingbird

day dreamer
06-24-2011, 12:55 PM
My fish finder has a hook on it . he he just kidding i dont have 1 of those fancy grafs my is just n color thats it sorry cant help

Double D
06-24-2011, 01:03 PM
Hummingbird.

gabowman
06-24-2011, 02:21 PM
I've always like the Lowrance products best so if I ever had that kind of money for a graph I'd go with Lowrance.

beagle man
06-24-2011, 04:52 PM
I have owned both and lowrance is my choice, got three of them and love them all

kazualobzerver
06-25-2011, 10:16 AM
Didn't see an option for a Hummingbird Super 60 flasher, that matches my technological skill level.

FAADAN
06-25-2011, 11:36 AM
I can't say a lot of good things about Lowrance customer service right now.

red ranger
06-25-2011, 04:30 PM
ihave the 898c si and a 789csi on front love them once you sit and adjust it the way you want you will see thing in a whole new way...... it does have a flasher on it also,,,ha ha

mduncan62
06-27-2011, 09:35 AM
I have had top notch customer service from Lowrance, and from HB.

FAADAN
06-27-2011, 10:13 AM
I have had top notch customer service from Lowrance, and from HB.

How about telling me how you do it. I have had a technical request in for over a week and all they do is ask questions and ignore my replies. I finally wrote a letter to the CEO of Lowrance. We'll see if that generates a response. I tried to register my unit on line and get a reply that there is a problem with the serial number, please call customer service. I call and either can't get though or get hung up on by their automated system.

beagle man
06-28-2011, 09:22 AM
never had a problem, wonder what is going on on your end, well I did have a problem one time. I was trying to use the cell phone and it kept getting noise causing the auto system to kick out on me. good luck
How about telling me how you do it. I have had a technical request in for over a week and all they do is ask questions and ignore my replies. I finally wrote a letter to the CEO of Lowrance. We'll see if that generates a response. I tried to register my unit on line and get a reply that there is a problem with the serial number, please call customer service. I call and either can't get though or get hung up on by their automated system.

FAADAN
06-28-2011, 01:03 PM
I guess I just don't have very good luck with repair folks. I took my trolling motor to Springfield last Wednesday to have it repaired. I called ahead of time and asked them if they had a backlog and they told me it would take 2 to 3 days to fix it. When I took it in they promised that it would be ready by today. I called up there this morning and I was told not only would the cost be about 2.5 times what they estimated, they did not have the parts in stock. I wouldn't have minded paying the extra money as I know they can't really guess the extent of the damage without looking at it. What I do mind is being promised that it would be ready today. They could have opened it up when I took it in and ordered the parts they needed and had it ready for me as promised. I took it to them instead of doing the job myself because I thought I would get it back sooner. Now I have to go on line and order the parts myself and do the job. It will save money in the long run and I won't be using them again.

Jigging15
06-28-2011, 08:31 PM
Sounds like a run of bad luck lately. I think we all go through that from time to time. I got the same run around last year on a trolling motor repair. Went three places and went with the more expensive but faster route. Ended up being more expensive and 3 weeks instead of 3 days as promised. So I no longer will be using them again either. Hope everything works out ok and you get back on the water soon.

FAADAN
07-06-2011, 11:14 AM
I guess I just don't have very good luck with repair folks. I took my trolling motor to Springfield last Wednesday to have it repaired. I called ahead of time and asked them if they had a backlog and they told me it would take 2 to 3 days to fix it. When I took it in they promised that it would be ready by today. I called up there this morning and I was told not only would the cost be about 2.5 times what they estimated, they did not have the parts in stock. I wouldn't have minded paying the extra money as I know they can't really guess the extent of the damage without looking at it. What I do mind is being promised that it would be ready today. They could have opened it up when I took it in and ordered the parts they needed and had it ready for me as promised. I took it to them instead of doing the job myself because I thought I would get it back sooner. Now I have to go on line and order the parts myself and do the job. It will save money in the long run and I won't be using them again.

I did a little troubleshooting and decided the armature was the bad part. Ordered an armature and brush kit because it contains all of the seals you need if you open it up and you might as well replace the brushes if you have it open. The parts cost a about $100 with $10 shipping. Put it back together in about half an hour and it works fine. Bottom line, don't bother taking your unit to the place in Springfield if you are just trying to get it fixed fast. I would have had it fixed by the time they promised it had I just ordered the parts the day I took it in to them, and at less than half the price they quoted. The unit got water in it due to worn seals, that corroded the commutator on the armature causing it to draw more current and heat up, destroying the windings.

Now, I'm going to try the tricks and the new transducer that Lowrance sent to see if my DSI unit works any better.

Jigging15
07-06-2011, 12:42 PM
Glad you go it fixed up and ready. Good luck with the Lowrance to.

FAADAN
07-09-2011, 01:11 PM
Got the Elite 5 DSI mounted back on the trolling motor and took it for a spin. I did a hard reset on the unit and uploaded the latest software update which also does a hard reset itself. I can now see the bottom in 180 feet of water (that's the deepest I've been in) and can even see what I think are fish now. I'm going to play with it a little more and figure out just what I'm seeing. I was going to take some screen shots but apparently the unit does not have that capability. At least if it does I haven't found the way to do it. The user's manual doesn't address it so maybe it's not a feature on this unit.