PDA

View Full Version : Minn Kota Powerdrive foot pedal problem



abarkley
01-18-2010, 06:27 PM
First thing this morning my motor wouldn't turn right or left when i pressed the foot pedal. It would turn on and off and the intermittent portion of the pedal worked. By the end of the day it would only turn left. Anybody got a clue as to what's wrong? I went by radio shack and bought some contact cleaner and sprayed the pedal and the connections and still no dice.

Barnacle Bill
01-18-2010, 07:10 PM
I would suspect a bad pedal. Can you borrow one to verify that?

CrappieKillerJigs
01-18-2010, 07:36 PM
i had somthing like this happend a picked up a new pedal from cabelas for $64.99 and havent had a prob. since

critter
01-18-2010, 09:37 PM
I had the same problem with mine bout once a year,just taken it by the cord and jig it up and down in the water....no kidding it works.I was told this by the minn kota people.Its corrosion on the terminals and this will take care of it but it will happen again eventually

Quicksilver1958
01-18-2010, 09:46 PM
I had the same problem with mine bout once a year,just taken it by the cord and jig it up and down in the water....no kidding it works.I was told this by the minn kota people.Its corrosion on the terminals and this will take care of it but it will happen again eventually

Guys, this works.. I had to do this to my Terrova pedal a few days ago.. I got me going but still had "dead spots" in the speed control. When I goy home from the lake I un plugged the foot control, sprayed a 50/50 water/vinegar solution into the pedal and let it set for a few minutes while working speed control etc. back/forth and then rinsed out.. Good as new..

CrappieKillerJigs
01-18-2010, 10:06 PM
i will have to remember this

Cane Pole
01-18-2010, 10:17 PM
Do what ya want, but water has impurities which promote corrosion. There are no exposed electrical connections inside the foot pedal, so the water will wash out dirt or grit. I do not know the IP rating of the pedals. I have had mine apart numerous times. The umbilical electrical connector should be properly cleaned and coated with a slight amount of bulb grease so to inhibit corrosion. MOAO

The V2 foot pedal truly sucks.

Barnacle Bill
01-19-2010, 12:02 AM
Test procedure for MK's foot pedals.

rushcreekoutdoor
01-19-2010, 12:03 AM
I first experienced it with my Powerdrive 40 about 3 1/2 yrs ago. I sent it to my friends (and yours) at Grizzly Jig and they fixed it muy rapido. I believe that it was some sort of fried circuit board.

Two weeks ago the same thing happened to my Powerdrive 80. I took it off and sent it to Grizzly and it turned out to be the foot control. Next time I will check that first, but, once again, Grizzly fixed it quick and very inexpensively.

THANKS GUYS AT GRIZZLY. YOU ARE THE FINEST.

RCO

bigbob
01-19-2010, 10:54 AM
I have had 3 go bad and finally called Minn Kota and a lady put me on hold and after a couple minutes, she returned and said they have never heard of the pedals going bad.
I informed her she needs to start reading the zillion complaints about them on all the fishing forums. She said she would pass on the info.

This was over a year ago and have not heard from them since.
I just had to purchase my fourth new pedal last week.

abarkley
01-19-2010, 11:06 AM
I would suspect a bad pedal. Can you borrow one to verify that?

I'm picking up a loaner today to check and see if it's the pedal.